[wellylug] accessing vfat partition

Lyndsay Mountfort lyndsaym at paradise.net.nz
Sun May 2 22:15:23 NZST 2004


Thanks Jamie

But this is weird - I swear I had tried exactly that, and failed. Now I 
try it again, and it works...

So I guess the problem is solved for now. But I did reboot in between 
this time. I get a strange response to umount when testing it where I  
get "/win_d: device is busy" all the time, with no programs running or 
terminals in that directory. So I rebooted to force the umount. So hey 
presto it all works now, and I've removed the noauto as well. I'm still 
getting the umount failure, but that doesn't actually matter 
particularly - I'm not really going to need to do that outside of 
testing /etc/fstab.

So thanks for your suggestion!

Lyndsay

Jamie Dobbs wrote:

>Try mounting with a umask=0000 - I had the same problem at one stage under Gentoo and this fixed it.
>
>-----Original Message-----
>From: wellylug-admin at lists.naos.co.nz
>[mailto:wellylug-admin at lists.naos.co.nz]On Behalf Of Lyndsay Mountfort
>Sent: Sunday, 2 May 2004 9:45 p.m.
>To: WellyLug
>Subject: [wellylug] accessing vfat partition
>
>
>Hi Luggers
>
>I used to have access to a vfat partition from my normal user account, 
>but this has got broken in the last few weeks, and I'm sure sure how.
>
>The mount directory is /win_d, with permissions 0777.
>
>The line from /etc/fstab is:
>
>/dev/hda5    /win_d    vfat    defaults,noauto    0 0
>
>When the partition is mounted, the permissions on /win_d change to 
>drwxr-xr-x, and of course only the root account gets access.
>
>I'm not sure how it got broken, or even that I didn't break it myself. I 
>did edit fstab to add read-only access to a NTFS partition, and can't be 
>sure that I didn't absent-mindedly edit the wrong line at some point, 
>then incorrectly correct it, if you see what I mean.
>
>But I've tried everything that I can think of, or glean from Google, man 
>mount and man fstab, to no avail. Can anyone help?
>
>Lyndsay
>
>
>  
>




More information about the wellylug mailing list