[wellylug] accessing managed switch

David Antliff dave.antliff at paradise.net.nz
Sun May 16 18:01:00 NZST 2004


On Sun, 16 May 2004, Rob Stockley wrote:
>
> Thanks but unfortunately no. Serial only. At the moment I can go next door and
> use doze to configure it.

Recently I tried to diagnose a strange Linux-only serial problem - it
turns out that the Linux serial driver handles the carrier detect rather
strangely. Windows 2000 seemed to handle it properly, but Linux would
start doing strange things if (like hanging up all the time, but my memory
is hazy) DCD wasn't what it ought to have been. We discovered this when we
tried using our serial cables we manufactured ourselves with Linux and
found they simply didn't work. I'm afraid I can't remember the details,
but we did conclude that it was a bug in the linux driver (ppc-linux
2.4.4). We also reworked all our serial cables slightly to work around
this.

This probably doesn't help you I'm afraid, and might even be a red
herring.

Do you have a serial monitor (one of those little in-line devices with
LEDs that light up showing the signal on each line)? If so, try comparing
between Linux and Windows.  Also, whats the DCD state?

You could also try with a simple RX/TX/GND cable.

-- 
David.




More information about the wellylug mailing list