[wellylug] strange power-related problem

Rob Stockley wellylug at mowgli.net.nz
Wed May 26 20:33:22 NZST 2004


I have the same symptoms on an ASUS A7N8X-X. I've tried various kernel 
rebuilds, different ram modules, different hdd's, different CDRW, and 
different PSU's - whew! - all to no avail. 

I suspect it is something to do with the save-to-ram feature on the mobo. When 
Linux shuts down it never actually turns off. I have to manually hit the 
switch. This, I believe, saves the shutdown state to ram which is then 
dutifully restored the next time I hit the button. I've tried disabling the 
feature in the BIOS and have tried various kernel boot parameters but still 
no joy. 

Easiest way to ensure it doesn't cause problems is to not turn the PC off. If 
I do turn the PC off it is not with the front panel button but with the wall 
switch. Hmmmm. I've thought of migrating to a 2.6 kernel to see if the 
problem persists - in fact when I get home from my next trip I'll do exactly 
that.

Rob

On Wednesday 26 May 2004 20:18, Damon Lynch wrote:
> Hi,
>
> Anyone know what the cause of this hardware problem could be?  A new
> Shuttle mini-PC will not boot up sometimes when power has not been
> switched off at the wall socket.  Sometimes, it just won't post -- there
> are no beeps, and the main fan does not slow down like it normally
> does.  There does not appear to be a pattern as to when it will or will
> not post.  However when the machine has had it's power totally cut, by
> turning off the power switch at the wall or removing the power cord,
> when the power is restored it appears to boot normally as one would
> expect.  Any ideas as to the cause of this problem?  I've not seen it
> before myself.
>
> Of course, it did not exhibit this problem when being tested in the shop
> it came from!
>
> Damon




More information about the wellylug mailing list