[wellylug] I blew it - lost a convert

Darryl Hamilton wellylug at addict.net.nz
Wed Sep 1 09:17:11 NZST 2004

FIXMBR replaced fdisk /mbr in the XP recovery console, so yes, he has :)


Mark Signal wrote:
> out of curiosity did you fdisk /mbr ?
> cheers
> Mark
> -----Original Message-----
> From: wellylug-admin at lists.wellylug.org.nz
> [mailto:wellylug-admin at lists.wellylug.org.nz]On Behalf Of John C Barstow
> Sent: Tuesday, 31 August 2004 10:39 p.m.
> To: Wellylug
> Subject: [wellylug] I blew it - lost a convert
> So, I've agreed to help a friend de-gunk their Windows box; and casually
> mention that if they had Linux they wouldn't have this problem. They're
> willing to give a go after I evangelize it, and lend me the box to set a
> dual boot environment.
> I grab a copy of Mandrake 10 from Disk Smith, reasoning that it's a good
> first distro and requires me to spend 0 minutes burning. A few clicks
> later, and we have a brand-new install.  Windows side is run through a
> few good cleaning cycles, Mozilla and OpenOffice are installed, and
> there is much rejoicing.
> They bring it home and decide to put in that new Radeon they've been
> meaning to get installed. Figure they'll boot it up and get the "new
> drivers installing" screen they're used to in Windows.
> Nothing works. It has been a total of two hours since I handed the
> machine to them, and I get a phone call.
> I attempt to boot into windows. System just sits there, not doing
> anything. Booting into Mandrake fails - turns out they got prompted
> about multihead support and hit the cancel button; presumably X is
> misconfigured now, pointing at (unused and unsupported) on-board video.
> My first priority is to make sure they can get into their familiar
> Windows side; I can always revisit Linux configuration later.
> Using the Mandrake installation CD, I check out the rescue menu and get
> a nice option - "Restore the Windows bootloader". That'll do it, I
> think.
> Wrong. Now the machine doesn't boot.  Oops, maybe the bootloader got
> corrupted somehow.  Grab the XP install disc, drop into rescue mode.
> Had a small panic when nobody knew the admin password; then remembered
> this was Windows. It was blank, of course.
> Now, I run FIXMBR. This should give me a nice, clean Windows bootloader.
> MBR writes to disk, claims success, sign of relief.
> Machine still doesn't boot. Is there something wrong with hard drive? I
> run Mandrake rescue, install linux bootloader into MBR.  Boots nicely
> (not into Windows, of course). That is to say, it finds LILO just fine
> and boots into linux without problem.
> Run FIXMBR again, as well as FIXBOOT. Claims of success, no joy.
> So the result of all this hard work is that they ended up with a machine
> that boots into text-mode linux.  Obviously with some work I could get X
> configured properly, but from their perspective I screwed their machine
> and they will end up reinstalling XP. Luckily they don't blame me
> personally and may even be willing to give Linux another go once their
> new hardware is playing nicely with Windows.
> But this is frustrating. Reasonably well-supported hardware, good
> install experience, couple of handy test boots, but such pain when I
> hand the machine back to the user. It's not fair. And what the $@#% is
> wrong with XP that I can't restore the bootloader? I've never had a
> problem on any other machine. Single hard drive, Windows partition right
> up front where no bootloader should have any trouble whatsoever. Rescue
> disk even sees all the files!
> Argh!

More information about the wellylug mailing list