[wellylug] NFS Query

Chris Hodgetts chris at archnetnz.com
Sat Feb 19 15:13:17 NZDT 2005


This is the RPC info on the machine that cant connect:

root at jenna:/# rpcinfo -p
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    391002    2   tcp    701  sgi_fam
    100003    2   udp   2049  nfs
    100003    2   tcp   2049  nfs
    100005    1   udp    602  mountd
    100005    2   udp    602  mountd
    100005    1   tcp    605  mountd
    100005    2   tcp    605  mountd
    100024    1   udp    710  status
    100024    1   tcp    713  status

I have , recomplied nfs support into the kernel as well

On Sat, 2005-02-19 at 14:44 +1300, Chris Hodgetts wrote:
> chris at jenna:~$ nmap localhost
> 
> Starting nmap 3.75 ( http://www.insecure.org/nmap/ ) at 2005-02-19 14:44
> NZDT
> Interesting ports on localhost (127.0.0.1):
> (The 1652 ports scanned but not shown below are in state: closed)
> PORT     STATE SERVICE
> 9/tcp    open  discard
> 13/tcp   open  daytime
> 22/tcp   open  ssh
> 37/tcp   open  time
> 111/tcp  open  rpcbind
> 113/tcp  open  auth
> 600/tcp  open  ipcserver
> 631/tcp  open  ipp
> 699/tcp  open  unknown
> 1234/tcp open  hotline
> 6000/tcp open  X11
> 
> Nmap run completed -- 1 IP address (1 host up) scanned in 0.450 seconds
> chris at jenna:~$
> 
> So I guess something "Is" running, and I assume that its rpcbind.. so
> this makes no sence 
> 
> 
> 
> On Sat, 2005-02-19 at 14:17 +1300, Cliff Pratt wrote:
> > Chris Hodgetts wrote:
> > > Hello, spent the last day trying to work this out:
> > > 
> > > Not sure what I am doing wrong: I have portmap on both machines.
> > > 
> > > Machine 1 has problems, Machine 2 has no problems at all....
> > > Machine 3 is the NFS Server, so I believe it to be a client issue as it
> > > can be mounted on Machine 2
> > > 
> > > Machine 1:
> > > 
> > > root at jenna:/home/chris# mount caitlin:/media/video /mnt/temp/
> > > mount: RPC: Program not registered
> > > root at jenna:/home/chris#
> > > 
> > > Machine 2:
> > > caitlin:/media/video on /mnt/network type nfs (rw,addr=192.168.100.5)
> > > 
> > > 
> > > Machine 1's portmap:
> > > 
> > > root at jenna:/home/chris# rpcinfo -p
> > >    program vers proto   port
> > >     100000    2   tcp    111  portmapper
> > >     100000    2   udp    111  portmapper
> > >     391002    2   tcp    701  sgi_fam
> > >     100024    1   udp   1023  status
> > >     100024    1   tcp    602  status
> > > root at jenna:/home/chris#
> > > 
> > > 
> > > Anyone know what could be happening?
> > > 
> > If Daniel's idea doesn't work out, is there another program 
> > running using port 111? eg a backup program.
> > 
> > Cheers,
> > 
> > Cliff
> > 
> > 
> 
> 




More information about the wellylug mailing list