[wellylug] LiveCD boot problem after changing DVD drive

Chyr Ye Hong hchyr at streamyx.com
Wed Jan 2 20:46:18 NZDT 2008


Hi all

Happy New Year!

I'm facing a strange problem. I have a Dell Inspiron 1501 laptop, which 
was booting a few LiveCD without problems. The LiveCD's are:

1. Gentoo 2006.0
2. TRK 3.1
3. Knoppix 5

A few weeks ago, I was having problems with the laptop's built-in DVD 
writer and Dell came to replace the driver unit. Ever since then, when I 
tried to boot the LiveCD, it always fail. The error is consistent: 
"attempting to mount cdrom:- /dev/sda ..." and it will just freeze with 
a kernel panic, since the LiveCD can't mount the CD contents and chroot 
to the CD file system.

The only exception is the Ubuntu 7.10 LiveCD, which seem to boot OK, and 
I can even do a successful installation from that CD.

Just to curiosity's sake, I tried to boot the LiveCD on another PC and 
it seem to boot fine. Also tried to boot the LiveCD from the laptop, but 
within VMware Server, the same error came up. I would have thought that 
VMware will create an abstraction layer to virtualize the DVD drive and 
avoid that problem.

So, can it be concluded that the new DVD drive is giving problems? But 
what could be different about a DVD drive that cause such a problem?


Hong




More information about the wellylug mailing list