[wellylug] dpkg stuff

Hugh Davenport hugh at davenport.net.nz
Thu Mar 27 15:25:46 NZDT 2014


What led up to it do you know?

On 2014-03-27 15:20, E Chalaron wrote:
> Hi all
> 
>  I managed to get my debian out of control
> 
>  #apt-get upgrade
>  Reading package lists... Done
>  Building dependency tree
>  Reading state information... Done
>  You might want to run 'apt-get -f install' to correct these.
>  The following packages have unmet dependencies:
>  libc6 : Depends: libgcc1 but it is not installed
>  E: Unmet dependencies. Try using -f.
> 
>  Ok ok will do ...
> 
>  #apt-get -f upgrade
>  Reading package lists... Done
>  Building dependency tree
>  Reading state information... Done
>  Correcting dependencies... Done
>  The following NEW packages will be installed:
>  libgcc1
>  0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
>  2 not fully installed or removed.
>  Need to get 0 B/43.1 kB of archives.
>  After this operation, 123 kB of additional disk space will be used.
>  Do you want to continue [Y/n]? Y
>  E: CANNOT GET DEBCONF VERSION. IS DEBCONF INSTALLED?
>  DEBCONF: APT-EXTRACTTEMPLATES FAILED: NO SUCH FILE OR DIRECTORY
>  dpkg: regarding .../libgcc1_1%3a4.7.2-5_amd64.deb containing
> libgcc1:amd64, pre-dependency problem:
>  libgcc1 pre-depends on multiarch-support
>  multiarch-support is unpacked, but has never been configured.
> 
>  dpkg: error processing
> /var/cache/apt/archives/libgcc1_1%3a4.7.2-5_amd64.deb (--unpack):
>  pre-dependency problem - not installing libgcc1:amd64
>  Errors were encountered while processing:
>  /var/cache/apt/archives/libgcc1_1%3a4.7.2-5_amd64.deb
>  E: Sub-process /usr/bin/dpkg returned an error code (1)
> 
>  Any suggestion where from that ?
>  Thanks
>  E



More information about the wellylug mailing list